Crusader Kings II: Finno-Ugric Unit Pack

Loading
Crusader Kings II
Base Game

This product requires the base game Crusader Kings II on Steam in order to play. You can not run this product without this game.

Crusader Kings II: Finno-Ugric Unit Pack
Enhance your Crusader Kings II experience with the Finno-Ugric Unit Pack. The Finno-Ugric Unit Pack adds seven new, unique unit models for Finnish, Lappish, Komi, Samoyed and Mordvin rulers.

Crusader Kings II explores one of the defining periods in world history in an experience crafted by the masters of Grand Strategy. Medieval Europe is brought to life in this epic game of knights, schemes, and thrones...

The Saxon Unit Pack and Finno-Ugric Unit Pack, all new content for Crusader Kings II are Now Available on Steam! The Saxon Unit Pack adds seven new, unique unit models for Saxon rulers. The Finno-Ugric Unit Pack adds seven new, unique unit models for Finnish, Lappish, Komi, Samoyed and Mordvin rulers.

2014-02-14

PC SYSTEM REQUIREMENTS

MINIMUM SPECS:

Minimum:
  • OS: XP/Vista/Windows7
  • Processor: Intel® Pentium® IV 2.4 GHz eller AMD 3500+
  • Memory: 2 GB RAM
  • Graphics: NVIDIA® GeForce 8800 or ATI Radeon® X1900, 512mb graphics memory required, Minimum resolution of 10248768
  • DirectX: Version 9.0
  • Storage: 2 GB available space
  • Sound Card: Direct X-compatible sound card
  • Additional Notes: 3-button mouse, keyboard and speakers, Internet Connection for multiplayer, Requires the base game Crusader Kings II

MAC SYSTEM REQUIREMENTS

MINIMUM SPECS:

Minimum:
  • OS: Mac OS X 10.6.8 or later
  • Processor: Intel Core Duo Processor (2GHz or better)
  • Memory: 2 GB RAM
  • Graphics: ATI Radeon HD 6750 / NVIDIA GeForce 320 / NVIDIA GeForce 9600 or higher
  • Network: Broadband Internet connection
  • Storage: 2 GB available space
  • Additional Notes: 3-button mouse, keyboard and speakers, Internet Connection for multiplayer, Requires the base game Crusader Kings II

LINUX SYSTEM REQUIREMENTS

MINIMUM SPECS:

Minimum:
  • OS: Ubuntu 12.04 LTS
  • Processor: IntelR PentiumR IV 2.4 GHz or AMD 3500+
  • Memory: 2 GB RAM
  • Graphics: ATI Radeon HD 6750 / NVIDIA GeForce 320 / NVIDIA GeForce 9600 or higher, 1024MB graphics memory required
You must be logged in to post a comment.
HRK Live Support