Mad Max - The Ripper

1 Rates
Add to Wishlist
Loading
  • Mad Max - The Ripper
Mad Max
Base Game

This product requires the base game Mad Max on Steam in order to play. You can not run this product without this game.

Following the theft of his V8 Interceptor by marauders, Max embarks on a perilous journey to reclaim his legendary vehicle. Max joins forces with Chumbucket, an "idiot savant sidekick", and commandeers an all-new vehicle capable of heavy customisation - the "Magnum Opus". Fighting his way toward his vehicle, Max will encounter many others throughout the outback, both friend and foe. Ultimately, Max quests to find the "Plains of Silence", a fabled land where he might find solace from his madness.

The Ripper - an additional fully customizable Magnum Opus car body.

PC SYSTEM REQUIREMENTS

MINIMUM SPECS:

Minimum:

 

  • OS: 64 bit: Vista, Win 7, Win 8, Win 10
  • Processor: Intel Core i5-650, 3.2 GHz or AMD Phenom II X4 965, 3.4 Ghz
  • Memory: 6 GB RAM
  • Graphics: NVIDIA GeForce GTX 660ti (2 GB Memory or higher) or AMD Radeon HD 7870 (2 GB Memory or higher)
  • DirectX: Version 11
  • Storage: 32 GB available space
  • Additional Notes: PlayStation 4 controller support

 

RECOMMENDED SPECS:

Recommended:

 

  • OS: 64 bit: Win 7 SP1, Win 8.1, Win 10
  • Processor: Intel Core i7-3770, 3.4 GHz or AMD FX-8350, 4.0 GHz
  • Memory: 8 GB RAM
  • Graphics: NVIDIA GeForce GTX 760 (3 GB Memory or higher) or AMD Radeon HD 7970 (3 GB Memory or higher)
  • DirectX: Version 11
  • Storage: 32 GB available space
  • Additional Notes: PlayStation 4 controller support

 

MAC SYSTEM REQUIREMENTS

MINIMUM SPECS:

Minimum:

 

  • OS: macOS 10.11.6
  • Processor: 3.2 GHz Intel Core i5 or greater
  • Memory: 8 GB RAM
  • Graphics: 2GB AMD R9 M290, 2GB Nvidia 680MX (See Additional Notes for more details)
  • Storage: 35 GB available space
  • Additional Notes: The game is supported on the following Macs. To check your Mac model and when it was released, select About This Mac from the Apple menu on your menu bar.
    • * All 15” MacBook Pros released since Late 2013 with a 2GB graphics card or better (1)
    • * All 21.5” 4K iMacs released since Mid 2017
    • * All 27” iMacs released since Late 2013 with a 2GB graphics card or better (2)
    • * All Mac Pros released since Late 2013
    • (1) The 15" Retina MacBook Pro released in Mid 2015 with an AMD Radeon R9 M370X graphics card is not officially supported
    • (2) Late 2012 models with an Nvidia 680MX graphics card are also supported.
    ——— The following Macs are capable of running the game but do not consistently meet the standards required for official support.
    • * All 13" MacBook Pros released since Late 2016
    • * 15" Retina MacBook Pro released in Mid 2015 with an AMD Radeon R9 M370X graphics card
    ———
    • Please note for your computer to meet the minimum requirements it must match or better all elements of the listed spec. For more detailed specifications check the Feral website.

 

LINUX SYSTEM REQUIREMENTS

MINIMUM SPECS:

Minimum:

 

  • OS: Ubuntu 16.04 or Steam OS 2.0 (64 bit required)
  • Processor: Intel i5 3.4GHz, AMD FX8350
  • Memory: 8 GB RAM
  • Graphics: 2GB Nvidia 660ti or better (driver version: 367.35)
  • Storage: 35 GB available space
  • Additional Notes: AMD and Intel Graphics Cards are not supported at the time of release

 

RECOMMENDED SPECS:

Recommended:

 

  • OS: Ubuntu 16.04 or Steam OS 2.0 (64 bit required)
  • Processor: Intel i7 3.6 GHz
  • Memory: 16 GB RAM
  • Graphics: 4GB Nvidia 970 or better (driver version: 367.35)
  • Storage: 35 GB available space
  • Additional Notes: AMD and Intel Graphics Cards are not supported at the time of release

 

You must be logged in to post a comment.
HRK Live Support