Total War: MEDIEVAL II – Definitive Edition EUROPE

1 Rates
Add to Wishlist
Loading
  • Total War: MEDIEVAL II – Definitive Edition EUROPE

Total War: MEDIEVAL II - Definitive Edition

Includes 2 items: Medieval II: Total War™ Kingdoms, Total War: MEDIEVAL II – Definitive Edition

Total War: MEDIEVAL II - Definitive Edition introduces the complete experience of the game with all the DLCs and feature updates that have been released since the launch. The Definitive Edition has been developed by CREATIVE ASSEMBLY and published by SEGA on November 15th, 2006.
Total War: MEDIEVAL II - Definitive Edition has hundreds and hundreds of hours of pure entertainment and joy for anyone that loves a compelling strategy game. The time has come for your reign, and gigantic battles where up to 10,000 warriors will clash await on awe-inspiring 3D battlefields that feature one of the most enchanting Medieval nations of both the Middle Eastern and the Western world. Prepare well, as managing an entire empire requires a lot of skill. Build entire cities, improve them, recruit massive armies or train your own. Diplomacy is another tactical tool that lets you hinder your opponents and trick your allies which will be important when dealing with things like the infamous Inquisition and even influencing the Pope. The Holy War can have only one winner, and the player decides if the one standing as the victor, in the end, is Islam or Christianity. A world made for conquering awaits.
Total War: MEDIEVAL II - Definitive Edition features big and realistic real-time battles where combat choreography got improved greatly,  the pace of battles is quicker, and finishing moves give each battle a gorgeous and visceral ending. Now, the single-player campaign stretches over three continents where we get to sail to the Americas and take on the mighty Aztecs. The user interface got a makeover so that it is much more accessible now, and with the optional short campaign, everyone can enjoy a quick and fun Total War match without going too deep into the many complex gameplay mechanics that are available.

PC SYSTEM REQUIREMENTS

MINIMUM SPECS:

Minimum System Requirements:

  • Microsoft® Windows® 2000/XP
  • Celeron 1.5GHz Pentium 4® (1500MHz) or equivalent AMD® processor
  • 512MB RAM
  • 11GB of uncompressed free hard disk space
  • 100% DirectX® 9.0c compatible 16-bit sound cardand latest drivers
  • 100% Windows® 2000/XP compatible mouse,keyboard and latest drivers
  • DirectX® 9.0c
  • 128MB Hardware Accelerated video card with Shader 1 support and the latest drivers. Must be 100% DirectX® 9.0c compatible
  • 1024 x 768 minimum display resolution
  • Internet (TCP / IP) play supported; Internet play requires broadband connection and latest drivers; LAN play requires Network card.

Important Note: Some cards may not be compatible with the 3D acceleration features utilized by Medieval II: Total War. Please refer to your hardware manufacturer for 100% DirectX® 9.0c compatibility.

MAC SYSTEM REQUIREMENTS

MINIMUM SPECS:

OS: 10.10.5
Processor: 1.8 GHz
RAM: 4 GB
Graphics: 256 MB
Mac OS: 10.10.5
Hard Disk: 32 GB
Input: Keyboard & Mouse

The following graphics cards are not supported: ATI X1xxx series, ATI HD2xxx series, Intel GMA series, NVIDIA 7xxx series and NVIDIA 8xxx series.

RECOMMENDED SPECS:

OS: 10.11.2
Processor: 2.4 GHz
RAM: 4 GB
Graphics: 512 MB
Mac OS: 10.11.1
Hard Disk: 32 GB
Input: Multi-button Mouse

The following graphics cards are not supported: ATI X1xxx series, ATI HD2xxx series, Intel GMA series, NVIDIA 7xxx series and NVIDIA 8xxx series.

LINUX SYSTEM REQUIREMENTS

MINIMUM SPECS:

OS:
Ubuntu 14.04
Steam OS 2.0 (NVIDIA & Intel Only)
Graphics Card:
Nvidia 600 series+ with Driver Version 352.55
AMD R7 with Mesa 11.2 driver*
Intel Iris Pro with Mesa 11.2 driver*

*IMPORTANT: AMD GPUS may require Ubuntu 15.10 or later. Mesa 11.2 driver still in active development.

RECOMMENDED SPECS:

OS:
Ubuntu 15.10
Steam OS 2.0 (NVIDIA & Intel Only)
Graphics Card:
Nvidia 700 series+ with Driver Version 352.55
AMD R9 with Mesa 11.2 driver*

*IMPORTANT: AMD GPUS may require Ubuntu 15.10 or later. Mesa 11.2 driver still in active development.

You must be logged in to post a comment.
HRK Live Support